NVIDIA 555 Testing

Hi together,

NVIDIA Just dropped the 555 Beta Driver.
CachyOS does already patch all required packages with explicit sync. This works on KDE and Gnome.

if anyone wants to test it, run following command:

sudo pacman -U https://mirror.cachyos.org/nvidia/lib32-nvidia-utils-555.42.02-2-x86_64.pkg.tar.zst https://mirror.cachyos.org/nvidia/lib32-opencl-nvidia-555.42.02-2-x86_64.pkg.tar.zst https://mirror.cachyos.org/nvidia/nvidia-dkms-555.42.02-2-x86_64.pkg.tar.zst https://mirror.cachyos.org/nvidia/nvidia-utils-555.42.02-2-x86_64.pkg.tar.zst https://mirror.cachyos.org/nvidia/opencl-nvidia-555.42.02-2-x86_64.pkg.tar.zst

For what it’s worth, that update command did not work for me. New packages installed without complaint, but on reboot I was just getting an unresponsive black screen (tried several kernels). After chroot to downgrade those packages back to 550, everything works correctly again.

Thats quite sad. Do you were able to gather some logs?

In the Discord Community its widely tested and so far not such a issue, like you have.

FYI, I have pushed a fix for the firefox crashes.

This was caused by the egl-wayland explicit sync patch. Just update your system with sudo pacman -Syu.

Hey, so, KDE right? If so, are you able to see the pointer and launch terminal or apps from terminal? if so, make sure you got set nvidia_drm.modeset=1 kernel parameter to your bootloader, in my case I added that extra command. FOR EXAMPLE:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet udev.log_priority=3 nvidia_drm.modeset=1”

The parameters are as default set, if youre using the above mentioned driver.
We are patching the NVIDIA driver, so the variables are default to true and the user does not need to set anything, see:

1 Like

Actually, retry with the pushed egl-wayland. That should maybe fix the issue.

You can also do following and pass it to the module:

also see:


Please keep us posted. It’ll help a lot.

Hey there! I’m testing that workaround right now, but I’m not sure where to put the " NVreg_EnableGpuFirmware=0" Mind explaining? Thanks for your time!

If you dont face issues, you dont need to set it actually.

But you can put it in /etc/modprobe.d/nvidia.conf to the other NVReg options.

Ran command, no issues during installation and post installation neither, I’m in the plasma desktop playing Senua’s Saga: Hellblade 2 without any issue.

Very good. We will push it soon probably to stable, after most issues are resolved.

Actually, nvidia also pushed an update now for nvidia-settings. Can be installed with:
sudo pacman -U https://build.cachyos.org/nvidia/nvidia-settings-555.42.02-2-x86_64.pkg.tar.zst

Ive adjusted above command also.
NVML has now also added Overclocking abilitiy, but its not yet exposed to nvidia-settings. But cool to see.

I’ve tested this driver with Games, not programs like blender or any other which are high GPU demanding, and So far experience has been smooth. No issues, steam big picture works perfectly fluid (enabling hardware acceleration), but enabling hardware acceleration on Steam makes this bug attached below.

Games I’ve tested: HB2, Helldivers 2, The Finals and AoE 4.

Yes, the bug with steam is pretty normal, thats also present on AMD Cards.

You can fix it with disabling in Steam Settings the Hardware Accel. Steam would need to fix that.

Thanks for the report!

1 Like

I re-tried updating to 555 this morning after a system update (including egl-wayland). I am still getting the same result: system starts to boot (I get the “early hook” message), but then the screen goes black (I don’t get a mouse arrow) and I am unable to get to a terminal to see any logs. My screen acts as if it’s getting no video signal and turns off.

I tried again using the NVreg_EnableGpuFirmware=0 command in /etc/modprobe.d/nvidia.conf, but that didn’t make any difference. Without logs, I realize this isn’t much help. When I revert to 550, everything works fine.

I did get this from journalctl:

May 22 05:43:04 cachyos-x8664 kernel: nvidia: loading out-of-tree module taints kernel.
May 22 05:43:04 cachyos-x8664 kernel: nvidia: module license 'NVIDIA' taints kernel.
May 22 05:43:04 cachyos-x8664 kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
May 22 05:43:04 cachyos-x8664 kernel: nvidia: module license taints kernel.
May 22 05:43:04 cachyos-x8664 kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 241
May 22 05:43:04 cachyos-x8664 kernel: nvidia 0000:81:00.0: vgaarb: VGA decodes changed: olddecodes=io+mem,decodes=none:owns=none
May 22 05:43:04 cachyos-x8664 kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  555.42.02  Mon May 13 16:48:14 UTC 2024
May 22 05:43:04 cachyos-x8664 kernel: nvidia_uvm: module uses symbols nvUvmInterfaceDupAddressSpace from proprietary module nvidia, inheriting taint.
May 22 05:43:04 cachyos-x8664 kernel: nvidia-uvm: Loaded the UVM driver, major device number 239.
May 22 05:43:04 cachyos-x8664 kernel: [drm] [nvidia-drm] [GPU ID 0x00008100] Loading driver
May 22 05:43:04 cachyos-x8664 kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:81:00.0 on minor 0
May 22 05:43:04 cachyos-x8664 kernel: nvidia 0000:81:00.0: vgaarb: deactivate vga console
May 22 05:43:04 cachyos-x8664 kernel: fbcon: nvidia-drmdrmfb (fb0) is primary device
May 22 05:43:04 cachyos-x8664 kernel: nvidia 0000:81:00.0: [drm] fb0: nvidia-drmdrmfb frame buffer device

Could this be a fbdev setting problem (i.e., set to 1 or 0?)

The log looks fine to me related to nvidia.

Which Graphics Card do you have? Does the dkms module compile correctly?

I have the Nvidia RTX 3090 GPU. It appears to me that the dkms modules are handled properly…first it removes 550 and then installs 555. For my kernels I don’t use the linux-cachyos-nvidia package(s), I just use nvidia-dkms. There hasn’t been any problems with my methodology with 550 (and the downgrade and re-installing of 550 dkms modules works fine).

That is very weird. Actually, in the discord we didnt get such a report yet across various graphics card.

Unfortunately the rollout of the 555 driver through the v4 repositories broke my system in exactly the same way I experienced during testing. Via chroot and the old kernel in my package cache I was able to recover my system by downgrading my kernel to the prior version. I guess I will just have to wait awhile and hope someone else can figure out what’s going on with my hardware case. I notice that the nvidia.conf file is gone now in /etc/modprobe.d…maybe there are some settings that would help, but I’ve tried a number during testing and it didn’t seem to.


That is quite sad. We had many positive feedbacks.
I’d suggest you to relay on the old nvidia-dkms version and blog temporarly the package.

I will make later a post for doing this,

Would you mind reporting the issue to NVIDIA? (best would be the forum=

The modprobe.d stuff got moved from /etc to /usr, so that the user can do overwrites in /etc