Virtualbox Kernel Driver not installed (rc=-1908)

I am unable to launch any VM created in Virtualbox. I was able to create a Windows 10 Pro and a Windows 11 Pro VMs. Then, I created a Kali Linux VM and a PopOS to play around and they both worked fine the whole day yesterday.
I shut down my system later at night and this morning, when I tried to launch the VMs, none of them are launching.
I got error message as follows:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing

/sbin/vboxconfig

as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more more information.

where: suplibOsInit what: VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On Linux, open returned ENOENT.

I was able to fix this issue in the past when I was running Fedora 39, but the commands are not working in CachyOS. I am new to Arch so chances are I am not even sure what commands should I type to solve this.

I already removed and reinstalled VirtualBox using the Terminal, Octopi and even CachyOS Package Installer. I always get the same error message.
I really don’t want to reinstall the OS, and avoid losing my created VMs for sure.

Any ideas?

Hi,

Are you using virtual-box-host-dkms?
https://archlinux.org/packages/?q=virtualbox-host-dkms

Or a different package? It requires a kernel module, otherwise it wont work.

Hi,

That’s a good question. I think I had the dkms version but then removed it. This is what I did the last time:

You need to install virtualbox-host-dkms to get the kernel module.

Not sure what’s wrong but even after installing the dkms version, I still get the same error.
I made sure to remove the previous installation and cleaned all orphaned packages and cache.
I needed to move on as I had some testing to perform on VMs and couldn’t wait any longer.
I ended up switching back to OpenSUSE where everything works like a charm.

I might give it another chance to CachyOS later this month.

Thanks for your help anyways!

cc @soulharsh007