Unable to install CachyOS on desktop

I have created a bootable USB stick, I’ve boot on my desktop, but after screen grub, my monitor becomes black and my keyboard comes out inactive. I guess it is a kernel problem. Does anybody have a solution?

1 Like


Could you share informations about your hardware ?

Anyways, here is a testing ISO which we are preparing for the next release:

Could you please test this one out ?

1 Like

My configuration:

Motherboard: Fujitsu d3401-b11 gs3;

CPU: Intel® Core™ i7-6700 × 8;

RAM: Gigastone Desktop RAM 16GB (2x8GB) DDR4 16GB DDR4- 2666MHz PC4-21300 Unbuffered Non-ECC;

GPU: Nvidia GeForce GT 1030.

I have tried to boot with Nvidia driver, but screen remains black. Tried testing ISO, but nothing changes.

Mhm, according the NVIDIA Driver support page, this is supported by the latest driver.
This is really weird, since we quite test much on nvidia cards.

Does the nomodeset option boot correctly?

Just a small question, how long did you wait during the boot when the screen got black?

It might take a little while for the desktop to come up, especially for slower USB sticks.

1 Like

I solve the problem! The issue gets in BIOS configuration: in my motherboard has been enabled TMP. It is necessary to disable it, getting into Advanced Security or into Trusted Computing BIOS section.
CachyOS the best Arch Disto I have ever known!


TMP, CSM, and one other should always be off.

1 Like

I can totally agree with this, it literally revived my old potato devices :slight_smile: