Please consider making a recovery iso

So I wasn’t expecting to have to do this but I am beginning to recognize a problem with my laptop. It’s been getting corrupted gradually over time using the system for regular daily activity. I have a strong hunch as to what that problem is. It’s the storage controller. It has an innogrit storage controller and after all the horror stories I have read about it, it claimed me as an unsuspecting victim.

This poses a conundrum. I don’t have any way of replacing the drive, and I would have to get a professional to swap it out. I have learned a number of ways to repair my file system but I have no quick access to an externally Bootable system. I also am not a huge fan of having to load the regular iso installer every time I need to resolve boot problems, which has required me to have to reconnect to my wifi every time, input my password, open the konsole application, run sudo pacman - Sy than have to run pacman - S to install the tools I need to fix it, it is so tedious, having to wait for the thing to boot before all the steps above, and most frustrating would be the fact that the desktop session is very unstable, often causing the system to become unresponsive under light work loads. I happen to know my own way to get around that but it would be nicer to have a more stable base environment that I can work with, And one that supports persistent changes I might make.

I was busy working on a special project of mine when disaster struck and usr lib just went down hard with quite a bit of corrupted modules. Tried to fix it, came to realize that it wasn’t the result of a potential misconfiguration on my behalf but flat out file damage. I plan on doing a chroot tomorrow, I already ran the partition manager from live environment to repair the partitions. I have no boot image at the moment on the device. It got deleted when I tried to regenerate the initramfs in recovery mode.

Actually, the default ISO already contains a script called “cachy-chroot”. This will guide you through the chrooting process and automatically chroot.

This should be enough for recovery :slight_smile:

Wiki Article is pending for that

Edit: Ok something is up. I may have found a source of my problem. But it is not clear if there isn’t a problem. Healthd was being triggered so I am a little uneasy.
Edit2: Ok I located the offending module. I wish i would have found this sooner. I also should have Tried looking at the logs. This resolved the problems I was having. Unfortunately my project got scrambled so now I have to figure out how to put the thing back together.