No Wayland Option on GDM

Hey Folks,

Installed Cachy with GNOME DE but i only have the option for X11 at login.
No option for Wayland although several Wayland packages are installed.

I’ve found this on the Arch wiki but dont wanna go play round unless its a known thing and theres an easier option?

Havent tried much to resolve myself other than running ‘–needs’ on a gnome install in pac in case there were packages missing but there isnt.
I’ve also confirmed GDM does not have Wayland disabled. #WaylandEnable=false
Oh and i also dont have any udev rules for GDM.

Happy to provide whatever info you need.

Key

And i fixed it…
I’ll leave this here in case it happens to someone else.

Went digging through logs looking for Wayland errors and found this

“GNOME Shell on Wayland was skipped because of an unmet condition check (ConditionEnvironment=XDG_SESSION_TYPE=wayland).”

Then the almighty Google led me to Reddit! :stuck_out_tongue:

https://www.reddit.com/r/wayland/comments/1768881/gdm_didnt_like_wayland/

sudo mv /run/gdm/custom.conf /run/gdm/Xcustom.conf

Then restart GDM

sudo systemctl restart gdm

So it seems that although /etc/gdm/custom.conf had - #WaylandEnable=false
/run/gdm/custom.conf had - WaylandEnable=false
No # therefore Wayland was disabled.

I did first try to comment out line in that file as root but upon restart it reverted to disabled again.
Only using mv did the file get renamed/ignored.
Login screen now shows me the gear in the bottom right and has either GNOME or GNOME -Xorg as options.

I found having a logging app like ‘gnome logs’ to be valuable in figuring that out so be good to include maybe in the base install?

1 Like

This is because gdm does block wayland on nvidia cards.
Its mentioned in the arch wiki how to workaround that:
https://wiki.archlinux.org/title/GDM#Wayland_and_the_proprietary_NVIDIA_driver

1 Like