No Kyber scheduler or module?

Post Edit: I must apologize for my hostile demeanor but while it may seem like a minor thing, as the saying goes, small grains of sand form a heap. As someone who has next to no control over his own life spanning 28 years, It really starts to make one bitter.
Cachy OS doesn’t support the kyber scheduler module? I tried setting elevator=kyber but it didn’t work. It is my favorite I/O scheduler and not being able to use it is really bumming me out. I am using the hardened cachy os kernel.

Edit: It isn’t loading the module. At a loss here.
Edit2: Seriously what is the deal? Is it because mq_deadline is not included? I have been told that it relies on mq_deadline. Which is not present. Which means I can’t use it? Why is it not there? And don’t you dare think about getting rid of the kyber scheduler what so ever. I will be a very unhappy camper if you catch my drift.
Edit3: Seriously?! CachyOS-Settings/usr/lib/udev/rules.d/60-ioschedulers.rules at master · CachyOS/CachyOS-Settings · GitHub
Every wants me to like linux but for whatever reason they love to force their changes on me! I am this freaking close to going back to windows 11! I can’t take it anymore! I hate Windows 11 like no tomorrow! But I am losing more and more control over how I am able to use Linux! The whole reason I switched to Linux is because of how awful Windows was. I also did so because I wanted to have more options! I cannot recommend anyone use it when features are always being ripped away without any input by any users outside a small circle. Solutions to past problems are rendered useless when the solutions fall victim to things like deprecation. Whenever someone like me asks for something, I end up seemingly ignored or disregarded. Why must everything be so proprietary?! This is the kind of stuff one would expect from a company like IBM and or Redhat to implement. I am sorry for my tirade but this has been growing problem I am faced with. I have no alternatives. None. The same situation I was in back in 2020 through 2022.

I don’t expect my frustrations to be acknowledged. It wouldn’t be anything out of the ordinary. I will post these two links here for reference.

We are not disabling kyber via the kernel. It is enabled and can be used with the udev rules

1 Like

How come I can’t find the module? I changed the udev rules. I searched the entire file system with three different broad searches that included text in files, regular expressions and file names. Is it possible that me using an alternative initramfs handler is causing this to happen? If so, How would I go about alleviating it. Here. look at this.


Also
Io scheduler config

And lastly
Loade modules
No kyber module is loaded.
I also set the boot parameter to use kyber kyber.data_prio=1 but that part is not being included during boot. So I cant figure what is going on. I have two screen shots. One pre search and one post search


Its not a module, its directly in the kernel.

…Gee. How would someone like me find out about that? Had me stumped. So in that case, how would I go about setting the kyber.data_prio=1 parameter? How can I be certain that it is enabled? The parameter is meant to force kyber scheduler into data integrity protection mode.

Im not sure, about the kernel parameter, but if you changed the udev rule, you can check in the sysfs to see, which io scheduler is used.
Currently on the phone, so ill let you later know the command

1 Like

Any idea on how long it will be before you give me the answer to the command I need to use? Thought I would follow up in case you may have forgotten.

Sorry, for the delay, see below:

❯ cat /sys/block/sda/queue/scheduler 
none [mq-deadline] kyber bfq 

~
❯ cat /sys/block/nvme0n1/queue/scheduler 
[none] mq-deadline kyber bfq 

~
❯ cat /sys/block/nvme1n1/queue/scheduler
[none] mq-deadline kyber bfq 

If you want to change to kyber, do following:
echo kyber | sudo tee /sys/block/nvme1n1/queue/scheduler