Linux kernel 6.9 and sleep not working correctly

Hi,

Anyone else having any issues with sleep with the new kernel 6.9?

The problem I am experiencing is that the computer seems to not sleep at all. It stays hot, and the battery is almost empty the next morning.

CPU is Intel core 7H

I dont think there is anything interesting in dmesg, but here it is anyways:

[ 3445.288445] PM: suspend entry (s2idle)
[ 3445.294663] Filesystems sync: 0.006 seconds
[ 3445.304702] Freezing user space processes
[ 3445.307236] Freezing user space processes completed (elapsed 0.002 seconds)
[ 3445.307247] OOM killer disabled.
[ 3445.307249] Freezing remaining freezable tasks
[ 3445.308484] Freezing remaining freezable tasks completed (elapsed 0.001 seconds)
[ 3445.308490] printk: Suspending console(s) (use no_console_suspend to debug)
[ 3445.359995] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: Asserting Reset
[ 3445.366108] intel-hid INTC1077:00: failed to get button capability
[ 3445.505658] ACPI: EC: interrupt blocked
[ 3932.863816] ACPI: EC: interrupt unblocked
[ 3932.921401] pci 0000:00:08.0: Setting to D3hot
[ 3932.933459] pci 0000:00:0b.0: Setting to D3hot
[ 3932.954346] intel-hid INTC1077:00: failed to get button capability
[ 3932.969314] iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
[ 3932.971222] i915 0000:00:02.0: [drm] GT0: GuC firmware i915/mtl_guc_70.bin version 70.20.0
[ 3932.983540] i915 0000:00:02.0: [drm] GT0: GUC: submission enabled
[ 3932.983543] i915 0000:00:02.0: [drm] GT0: GUC: SLPC enabled
[ 3932.983746] i915 0000:00:02.0: [drm] GT0: GUC: RC enabled
[ 3932.984225] i915 0000:00:02.0: [drm] GT1: GuC firmware i915/mtl_guc_70.bin version 70.20.0
[ 3932.984227] i915 0000:00:02.0: [drm] GT1: HuC firmware i915/mtl_huc_gsc.bin version 8.5.4
[ 3932.998324] i915 0000:00:02.0: [drm] GT1: GUC: submission enabled
[ 3932.998325] i915 0000:00:02.0: [drm] GT1: GUC: SLPC enabled
[ 3932.998446] i915 0000:00:02.0: [drm] GT1: GUC: RC enabled
[ 3933.022629] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: DSP1: Firmware version: 3
[ 3933.022634] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: DSP1: cirrus/cs35l41-dsp1-spk-prot-10431a63.wmfw: Fri 31 Mar 2023 10:42:49 W. Europe Daylight Time
[ 3933.084570] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: DSP1: Firmware: 400a4 vendor: 0x2 v0.65.0, 2 algorithms
[ 3933.085663] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: DSP1: cirrus/cs35l41-dsp1-spk-prot-10431a63-spkid1-l0.bin: v0.65.0
[ 3933.085668] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.0: DSP1: spk-prot: C:\Users\tyang\Desktop\Product Setting\SmartAMP\ASUS\ASUS_Zenbook\2023Projects\UX3405MA\Tuning_release\06082023\UX3405UM_19p5dB_Mock_VECO_Lch_finish_ID_6p83_US_Xmax0p65.bin
[ 3933.113297] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.1: DSP1: Firmware version: 3
[ 3933.113299] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.1: DSP1: cirrus/cs35l41-dsp1-spk-prot-10431a63.wmfw: Fri 31 Mar 2023 10:42:49 W. Europe Daylight Time
[ 3933.124245] iwlwifi 0000:00:14.3: Not valid error log pointer 0x0027B0C0 for RT uCode
[ 3933.124270] iwlwifi 0000:00:14.3: WFPM_UMAC_PD_NOTIFICATION: 0x1f
[ 3933.124279] iwlwifi 0000:00:14.3: WFPM_LMAC2_PD_NOTIFICATION: 0x1f
[ 3933.124285] iwlwifi 0000:00:14.3: WFPM_AUTH_KEY_0: 0x80
[ 3933.124293] iwlwifi 0000:00:14.3: CNVI_SCU_SEQ_DATA_DW9: 0x0
[ 3933.125146] iwlwifi 0000:00:14.3: RFIm is deactivated, reason = 4
[ 3933.174534] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.1: DSP1: Firmware: 400a4 vendor: 0x2 v0.65.0, 2 algorithms
[ 3933.175178] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.1: DSP1: cirrus/cs35l41-dsp1-spk-prot-10431a63-spkid1-r0.bin: v0.65.0
[ 3933.175181] cs35l41-hda spi1-CSC3551:00-cs35l41-hda.1: DSP1: spk-prot: C:\Users\tyang\Desktop\Product Setting\SmartAMP\ASUS\ASUS_Zenbook\2023Projects\UX3405MA\Tuning_release\06082023\UX3405UM_19p5dB_Mock_VECO_Rch_finish_ID_6p83_UX_Xmax0p65.bin
[ 3933.273506] mei_gsc_proxy 0000:00:16.0-0f73db04-97ab-4125-b893-e904ad0d5464: bound 0000:00:02.0 (ops i915_gsc_proxy_component_ops [i915])
[ 3933.274148] OOM killer enabled.
[ 3933.274151] Restarting tasks … done.
[ 3933.278128] random: crng reseeded on system resumption
[ 3933.352687] PM: suspend exit
[ 3933.411501] iwlwifi 0000:00:14.3: WRT: Invalid buffer destination
[ 3933.566433] iwlwifi 0000:00:14.3: Not valid error log pointer 0x0027B0C0 for RT uCode
[ 3933.566467] iwlwifi 0000:00:14.3: WFPM_UMAC_PD_NOTIFICATION: 0x1f
[ 3933.566478] iwlwifi 0000:00:14.3: WFPM_LMAC2_PD_NOTIFICATION: 0x1f
[ 3933.566485] iwlwifi 0000:00:14.3: WFPM_AUTH_KEY_0: 0x80
[ 3933.566493] iwlwifi 0000:00:14.3: CNVI_SCU_SEQ_DATA_DW9: 0x0
[ 3933.567327] iwlwifi 0000:00:14.3: RFIm is deactivated, reason = 4
[ 3937.653724] wlan0: authenticate with 44:f0:34:ae:63:38 (local address=b0:3c:dc:7f:20:fb)
[ 3937.654324] wlan0: send auth to 44:f0:34:ae:63:38 (try 1/3)
[ 3937.683491] wlan0: authenticated
[ 3937.684597] wlan0: associate with 44:f0:34:ae:63:38 (try 1/3)
[ 3937.685754] wlan0: RX AssocResp from 44:f0:34:ae:63:38 (capab=0x11 status=0 aid=7)
[ 3937.687808] wlan0: associated
[ 3937.704192] Ignoring NSS change in VHT Operating Mode Notification from 44:f0:34:ae:63:38 with invalid nss 3
[ 3937.704198] wlan0: Limiting TX power to 30 (30 - 0) dBm as advertised by 44:f0:34:ae:63:38
[ 3996.996211] [UFW BLOCK] IN=wlan0 OUT= MAC=b0:3c:dc:7f:20:fb:44:f0:34:ae:63:37:08:00 SRC=10.0.0.138 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2
[ 4121.976061] [UFW BLOCK] IN=wlan0 OUT= MAC=b0:3c:dc:7f:20:fb:44:f0:34:ae:63:37:08:00 SRC=10.0.0.138 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2
[ 4247.265201] [UFW BLOCK] IN=wlan0 OUT= MAC=b0:3c:dc:7f:20:fb:44:f0:34:ae:63:37:08:00 SRC=10.0.0.138 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2

Forgot to mention, this happens with the linux-cachyos and linux-cachyos-lto kernels.

Dont know if there is any more info that could be interesting. Nothing particular in journal either.

You can try to downgrade the kernel from the archive: CachyOS - Repo

Yes, it works fine with the 6.8 kernel. Tested now.

Edit: Same issue with the original Arch kernel, so I suppose this is an upstream bug. However, I have not managed to find any reported bugs about this.