Legion 5 Pro 16IAH7H No HDMI Output

I am unable to get output on my HDMI with a fresh install of CachyOS. The behavior persists whether I am using X11 or Wayland. KDE appears to detect the HDMI connection and asks how I want to display the new monitor, but it does not appear to matter what I select, it never outputs. I am using all the default options and have not altered or added any kernel parameters or config files.

I have confirmed that HDMI Out works on a fresh install of OpenSUSE Tumbleweed with the Nvidia drivers installed both on X11 and Wayland, so I know the BIOS is configured where the output is possible. A cursory seach for Arch documentation did not yield any advice that worked on a previous install.

Systems specs

  Host: CompyL5C Kernel: 6.9.6-2-cachyos arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.1.0 Distro: CachyOS
  Type: Laptop System: LENOVO product: 82RF v: Legion 5 Pro 16IAH7H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76461 WIN
    serial: <superuser required> UEFI: LENOVO v: J2CN57WW date: 01/08/2024
  ID-1: BAT0 charge: 73.3 Wh (94.9%) condition: 77.2/80.0 Wh (96.4%)
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP cache: L2: 11.5 MiB
  Speed (MHz): avg: 1406 min/max: 400/4600:4700:3500 cores: 1: 393 2: 400
    3: 400 4: 400 5: 4566 6: 400 7: 2132 8: 400 9: 1187 10: 4251 11: 400 12: 400
    13: 2641 14: 1764 15: 400 16: 3292 17: 400 18: 3500 19: 400 20: 400
  Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 555.52.04
  Device-3: Bison Integrated Camera driver: uvcvideo type: USB
  Display: wayland server: X.org v: with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting dri: iris
    gpu: i915,nvidia resolution: 1707x1067
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.2-arch1.2
    renderer: Mesa Intel Graphics (ADL GT2)
  API: Vulkan v: 1.3.285 drivers: nvidia,intel surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
  Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.9.6-2-cachyos status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi
  IF: wlan0 state: up mac: a0:29:42:71:dc:1b
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp52s0 state: down mac: e8:80:88:1e:ef:21
  Device-1: Intel AX211 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: A0:29:42:71:DC:1F bt-v: 5.3
  Local Storage: total: 1.39 TiB used: 20.55 GiB (1.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: MZVL21T0HCLR-00BL2
    size: 953.87 GiB
  ID-1: / size: 463.76 GiB used: 19.99 GiB (4.3%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot size: 2 GiB used: 575.9 MiB (28.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 463.76 GiB used: 19.99 GiB (4.3%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 463.76 GiB used: 19.99 GiB (4.3%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-5: /var/tmp size: 463.76 GiB used: 19.99 GiB (4.3%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-1: swap-1 type: zram size: 15.35 GiB used: 768 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 15.35 GiB used: 4.21 GiB (27.4%)
  Processes: 421 Uptime: 7m Shell: fish inxi: 3.3.35

Provide a sudo cachyos-bugreport.sh after plugging it in.

It looked like an EDID issue so I tried another monitor, same behavior. A Dell monitor and a TV, neither get video to them.

I think I have chased it down to as most likely an Nvidia driver bug for version 555. Every distro that works has used an older driver version. Could be quite specific down to laptop or GPU model so not exactly useful for the CachyOS team. So the answer is to install an older driver version till Nvidia fixes the bug.