How to update grub on ZFS

I need to add some boot parameters to the kernel but not sure how to do that when using ZFS on CachyOS?

Hi and welcome,

You simply add the boot parameters to /etc/default/grub and then regenerate the entries.
Anyways - if youre using ZFS I would suggest to reinstall with systemd-boot or refind, since grub does only support a limited feature set from zfs which kinda limits zfs at all, for example zstd compression does not work with grub.

Thanks, but how do I update the settings? There is no update-grub command.

Either you reinstall a kernel, then it will automatically update the entries with grub-hook or you run following command after changing in /etc/default/grub:

sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Thanks again. I think I tried that but I don’t have a grub-mkconfig either. Maybe I am using systemd-boot. How would I tell?

Please check if their is content in /boot/loader/entries.
If you have entries in their, then you’re using systemd-boot.

If you are using systemd-boot, then please add to the LINUX_OPTIONS array your additional boot entries in /etc/sdboot-manage.conf

After that run:
sudo sdboot-manage gen

Excellent, thank you. That worked and noted as I’m trying to get iGPU passthrough to work into a Proxmox VM and will probably have to make a few changes.

~ cat /proc/cmdline
initrd=\initramfs-linux-cachyos.img zfs=zpcachyos/ROOT/cos/root rw zswap.enabled=0 nowatchdog splash nomodeset i915.force_probe=4680
1 Like

Sorry to be a bother but what is the CachyOS equivalent of…

~ update-initramfs -u -k all
-bash: update-initramfs: command not found

Update: after some more googling, I hope it’s mkinitcpio -P otherwise I may have borked my system… nope, it rebooted okay :slight_smile:

Yes, we are archlinux based, which uses mkinitcpio. Thats fine.

Right. I, and a few friends, have been using Manjaro for the last 3 years up until I “discovered” CachyOS back in January. Now they are all running CachyOS with Plasma 6 and I’m left with a Proxmox VM that is not performant enough for daily use so I’ve been using Plasma 5 installed directly on the Debian Proxmox host, which is a no-no, but kind of works. Now my new Minisforum MS-01 has finally been delivered I’m desperately trying to get iGPU passthrough working so I can use that CachyOS VM for real. Sorry for rambling, this is just a misc comment about being really keen to get more into CachyOS and I appreciate the effort you put into supporting it.

Glad that you and your friends found CachyOS and like it.

CachyOs has actually a lot of features, which are people slowly recognizing. :slight_smile:
We should make a dedicated feature page in the future, to bring more information about.