High FPS but choppy gameplay in CS2 in fullscreen - KDE

Hello guys, so far I love every aspect of cachyos but I’ve got a weird issue.
When i try to play CS 2 in fullscreen mode I have high fps (i cap it at 200fps, uncapped goes 400+ but its unneccessary load for my GPU since my monitor is 165hz) but the gameplay looks choppy, almost as if its either low on fps or low in monitor refresh rate when it is not. The problem is fixed when i switch the Video mode from Fullscreen to Windowed and use ALT+F3 to hide the tilebar and put CS 2 on top of other applications, this “emulates” fullscreen mode but infact it is windowed, it gives me smooth as butter gameplay but I’d still want to use Fullscreen mode and was wondering if anyone else in here had similar problem and has some solution for it.
I’ve tried enabling/disabling screen tearing from KDE display settings - no luck.
Sometimes when i switch from Windowed to Fullscreen and vice-versa it fixes itself.
Every other game runs perfectly fine - Overwatch 2, Rocket league, CS 1.6, Dota 2, etc.

Some ideas to test:

  1. Different versions of proton & wine (proton-cachyos, proton-ge, wine-cachyos, wine-ge). With protonup-qt you can also install different versions.
  2. Different kernels linux-cachyos-bore, etc… Also when in doubt: the official archlinux kernel (sudo pacman -S linux) to make sure the cachyos patched kernels aren’t at fault.
  1. I play the linux native version of CS2
  2. I installed the latest arch linux kernel, will reboot and test it now

RE: tested with default arch kernel, same story, i think it has something to do with GPU driver or KDE itself, even though i tested it with GNOME today and had same experience.

I think I read some other reports with this problem somewhere else.

I’m not sure, but if I remember correctly, the explanation was that this was a known problem with the nvidia drivers (don’t remember if reverting to earlier versions fixed it or not).

What’s your GPU?

Ah yes I remember:

A1RM4X on youtube made a video a few weeks ago showing this problem. It was caused by the nvidia drivers, and if I remember correctly, reverting to an earlier version fixed the problem.

My GPU is AMD RX 6600 XT 8GB, using the latest mesa driver from cachyos repo, everything on the system is updated, other games have no issues at all - fullscreen/borderless/windowed give exactly the same smooth experience.

Is there any GUI tool/app like AMD Software from Windows 10 to configure the gpu?

Sometimes when i switch the windowed mode to fullscreen it fixes itself, but when i quit the game and start it again after couple of hours issue still remains unsolved.

If I remember correctly, for A1RM4X is was caused by wayland. Playing on X11 fixed the problem. (but this was on nvidia).

You can try logging into X11 (menu is at the bottom left or right of the login screen).

I’ve just tried X11 session, it gives me way way worse fps and it’s still choppy with the difference that Windowed mode doesn’t solve it as in Wayland session. + i use jump and duck binds on my mouse wheel and it doesn’t register properly as under Wayland, so i will be sticking to wayland. It’s not that big of a deal to use windowed mode and tile it up as a fullscreen app but i find it very weird that it works for some time, then i restart the game and its choppy again but the FPS remains high and stable. One thing i noticed, on X11 in cs 2 it says i am running on 165hz whereas in Wayland it tells me i use 164Hz , not sure if that changes anything but ye.

As it’s only with CS2, I guess its a problem with that game. → you should file a bug report with that game & they’ll certainly direct you further.

I don’t think so. This is probably a digits rounding difference in how the ui is presenting the info.

One more thing to try: mesa-git (from the cachyos repos).

sudo pacman -S mesa-git (and also lib32-mesa-git on the same line if you use steam).

Make sure to note down all the packages it will replace, so that you can easily revert back if you want (mesa-git includes everything, but the normal mesa is separated into several different packages, including vulkan-radeon, etc… And all of them have to be listed together on the same sudo pacman -S line to replace mesa-git, otherwise you will have conflicts).

This needs a reboot to become active.

Try to put CS2 to “Fullscren Windows” instead of “Fullscreen”

Should fix the issue

I’ve tried this, no change whatsoever.

Will try with mesa-git tomorrow morning and report back on the results.

Did you install the sdl2 and sdl12-compat packages? It might help to have the sdl2 and sdl12-compat packages installed. Second, what kind of monitor are you using? AMD is known to have problems with hdmi2.1

The issue was fixed by unchecking ‘enable screen tearing’ in KDE’s display settings, but in that scenario CS2 becomes playable and very smooth in fullscreen mode whereas every other game becomes choppy like CS2 was in fullscreen with screen tearing on. I did install sdl2 package and my monitor is Acer 165hz running with display port.

1 Like

Good find :+1:

As this is the only game with this behavior, you might want to report this to CS2, and perhaps also ask the kde development mailing list, to see if in their opinion this is something that should be fixed by the CS2 developers, or somewhere else.

Would you mind to install the “linux-cachyos-rc” kernel:

sudo pacman -S linux-cachyos-rc linux-cachyos-rc-headers

After that install a kwin:

sudo pacman -U https://archive.cachyos.org/kernel/kwin-6.1.2-4-x86_64_v3.pkg.tar.zst

This contains a fix for tearing and should hopefully help.

@MsiQ be aware that with the 6.10rc1 to rc7 kernels there is a confirmed bug on the amd drm gitlab. It causes display corruption on AMD 6000 series (7000 series are fine) @ 120hz & 144hz (60hz is fine). At least on KDE wayland . I guess your 165hz will be corrupted as well.

This has been confirmed by people with several 6700 & 6900 cards (& on the mailing list), and is caused by the 6.10rc amd drm patches. (I have spent 2 days bisecting the kernel to confirm that).

Of course, it would be interesting to see if you get the problem as well.

Sorry for late answer, today i’ve installed a dual boot Win10 and Cachyos in case i mess something up and have backup to play.

So, I have installed the 6.10rc7-2 cachyos kernel and installed the kwin package (i did -Syu beforehand and kwin was already latest version). So far with disabled screen tearing option in KDE CS2 works smoothly. Will test with couple reboots and changes of settings if it keeps the performance or it degrades as on 6.8 kernel.

No issues with the 165hz monitor whatsoever, running alright, no glitches, no lags, no issues at all. Now playing Dota2 to see if there is any issue with it. Will keep you updated.

UPD: update on Dota2, best fps and smoothest experience i’ve ever had, not even under Vulkan on Win10 i have such performance. Insane. Right now installing Rocket League to check if the screen tearing issue is gone, so far both CS2 and Dota2 run perfect.

1 Like