Does not boot system ERROR: '/dev/disk/by-label/' device did not show up after 30 seconds

Hi :wave:
I switched from windows on Linux and choose cachyos, used it for two month and very like it. But today, I’m updated archiso by using cachyos package installer and after reboot I can’t started my OS.
Help me please, what can I do for solve this problem?


It seems like you are booting into the ISO, checking above image.
Could it be that the USB Stick is corrupted?

I don’t use USB stick. System normally worked before upgrading archiso package with CachyOS Hello program. Early have problem with hooks, and now hooks work, but system do not boot.

Looking the above hooks, it looks like you are booting into a Live ISO somehow…

So, any ideas how I can resolve this?

Of course I can reinstall system, but all information will be lost. I can give you more information about my system, but you need to say me what I need to do :frowning:

I have a flash drive with the install file, but can I save the system configuration files?

Saw that you did reinstall. Hope everything is fine now.
As written above, it heavily looked like it is booting from the USB Stick/ISO

check your grub.cfg file

i have the same error but different circumstances, fresh install using offline mode and i boot right into that exact screen except /dev/disk/by-label is present. online install mode just errors out during install (i think during package installs…?).

Offline is not supported anymore due various issues with the new archiso release.
With the upcoming release, it wont be possible to use it anymore.

Sorry. The maintenance work for it is just too much.

1 Like