Cant get installation to work on ROG ALLY

Unable to finalize my install. I have a dual boot system. Windows and previous Bazzite install. Tried to wipe the bazzite partitions, all 3 of them, and try to install on the empty segment.

/Tried to install using replace and refit option. Probably need to make the manual partitions?

Have the same issue, guess i go back to mintlmde

@LeoJ @Jakkemon

You are both installing it wrongly and using another boot Parition, see:

install: error writing '/boot/a25c7bd118b14cdba215f197b0247bc5/6.9.3-1-cachyos-deckify/initrd': No space left on device
Error: could not copy '/tmp/kernel-install.staging.oYRKrD/initrd' to '/boot/a25c7bd118b14cdba215f197b0247bc5/6.9.3-1-cachyos-deckify/initrd'.
/usr/lib/kernel/install.d/90-loaderentry.install failed with exit status 1.

Increase your boot parition or use the erase disk option.

i blanked my entire drive still fails, i may need a no shit answer tp fix this cant install on rog… system my god evertyone is a fanboy do this ok done do that done ok 1hr later still fails and linux is great noway good thing i can restore back to windows in <10 min

Then please provide a log. It will prompt you to upload the log and give you then the URL.

sorry i think I am finished with this… tired of being everyone’s beta tester. i do apprciate your timely response though.

Everything good, its just problematic about complaining that something is not working, but then not providing logs.
If the installer is failing, then it does even ask you to upload the log. The only thing you need to do, his forwarding the URL from your device screen to the forum or equal.

The replace option is not working, if the previous installed operating system has a too small /boot parition. So, please use the “Erase Disk” Option.

Thank you for your help. Where could a total noob like me, find instruction for manual partiotioning.

Partitions, mountpoints etc…

The Erase Disk Option does everything for you :slight_smile:

On my Ally i have 1 SSD. Im trying to install dual boot, so that windows installation is untouched. You mean i can use the Erase Disk option to create dual boot installation?

you need an EFI partition (FAT32) 1GB minimum 2GB recommended mounted at /boot and flagged as boot, a root partition (BTRFS, ext4, f2fs, xfs) mounted at /

THX so much. Running install now.

WORKS! Got into OS. Now need to find how to install HHD, Decky etc…

Should i run the “Install Gaming Packages” list in the Tweak section?

Those are already installed on the Handheld Edition.

1 Like

HHD is preinstalled and preconfigured.

Decky Loader you (probably) need to install with their provided script

1 Like

Managed to install Decky Loader. It does not show HHD. Also cant find it through “shop”. Can you elaborate on what you mean that HHD is preinstalled, and how do i get it working?

HHD is enabled out of the box. You can check if it is running via hhd-ui

If you want to access Handheld Daemon in Game-Mode you manually need to install hdd-decky it in Desktop mode then reboot.

1 Like