CachyOS GUI Installer error when handling keyring

Greetings,

The current CachyOS GUI Installer ( cachyos-kde-linux-240512.iso ) has a bug when handling the Archlinux Keyring.

How to replicate

Simply start a normal installation via the Installer presented in the CachyOS-Hello popup.

The following error occurs after making your whole set of selections, and the Installation starts:


Workaround

Before(!) running the installer the first time, open a terminal, and perform the following commands:

sudo pacman -Sy archlinux-keyring
sudo pacman-key --populate

Afterwards, the installer from the CachyOS-Hello popup works fine.

This workaround only works if the installer has not run into the error yet - if it has, a reboot is required to apply this workaround without a hassle.

3 Likes

Thanks for the tutorial.

Yes, this is somewhat problematic, since this is not reproduceable. We are ranking the mirrors before importing the keyring, and somehow either at the copy process or fetching the “new” keyring is a failure.

I could never reproduce this issue on my machine or in QEMU Installation. Ive tried to mitigate this in the last release, to move the mirror ranking before installing the keyring, it helped for some people but still not a omplete solution.

Greetings,

Wouldn’t simply running those two lines at the very start of the installer before anything else definitely solve the issue?
The keyring package is small, so mirror selection should not really matter at that point yet.

Normally not, maybe its just “luck”. Because the ISO’s keyring is something different then the targets keyring.