Brightness not working

I just installed cachy os on my laptop and the brightness is not working it change value but doesn’t make any changes to the brightness please could someone help me out ?

I can tell you right now that there are three possibilities. A. You haven’t tried modifying it in system settings. B. Your device is not exposing the firm ware module needed to manipulate it. Or C. You don’t have a module available that would allow it. The first two can potentially be worked out, but the third one, your kinda SoL.

That highly depends on which hardware you have. Some laptops also do not support it tho and might require some hacky workarounds. Provide logs and hardware informations.

I typed this in terminal : $ inxi -G
Graphics:
Device-1: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] driver: nvidia
v: 555.52.04
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel
Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
loaded: modesetting,nvidia dri: radeonsi gpu: amdgpu
resolution: 1920x1080~144Hz
API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast
platforms: gbm,x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.1.2-arch1.2
renderer: AMD Radeon Graphics (radeonsi renoir LLVM 17.0.6 DRM 3.57
6.9.6-3-cachyos)
API: Vulkan v: 1.3.285 drivers: nvidia,radv surfaces: xcb,xlib

OS: cachyos rolling
Kernel: x86_64 Linux 6.9.6-3-cachyos
Uptime: 31m
Packages: Unknown
Shell: fish 3.7.1
Resolution: 1920x1080
DE: KDE
WM: KWin
GTK Theme: Breeze-Dark [GTK2], Breeze [GTK3]
Icon Theme: breeze-dark
Disk: 58G / 721G (9%)
CPU: AMD Ryzen 7 5800H with Radeon Graphics @ 16x 4.463GHz
GPU: NVIDIA GeForce RTX 3050 Ti Laptop GPU
RAM: 3071MiB / 15387MiB

Mind sharing what brand of laptop and model it is? That would be helpful information to have on hand. Even better, it would be beneficial to know the bios version number associated with the device.