Bluetooth Disabled on startup

Hey yall im back with another problem lol. Maybe its me? Maybe its the Install who knows.

So my issue is since install which is about… 1 and 1/2 week ago (fresh install) I had a problem where the bluetooth was like auto-disabled and on every reboot i have to sysctl bluetooth enable, now even then I have gone the through the GUI and enabled the box’s where they say “enable bluetooth”. So what im asking is what command or fix do I need to do to keep it enabled. If anyone has any questions feel free to ask


Please try sudo systemctl enable --now bluetooth.service


My Bluetooth does not work anymore too.
I switched the Kernel from RC to Normal and it is still not working.

I tried to reinstall bluez, " sudo systemctl enable --now bluetooth.service" doesn’t do anything. Tried out blueman. Before it was working. After installing RC-7-5 it seems to break or new Kernel. (Not sure).

oh, I see.
Yes, that seems to be an upstream issue.

Weve got a bunch of reports related to the 6.9 Kernel and Bluetooth. There is a workaround for this (if youre facing that issue): 218757 – Direct firmware load for mediatek/BT_RAM_CODE_MT7961_1a_2_hdr.bin failed with error -2

Check with dmesg if its the same adapter. There is a firmware attached, which can be copied to the firmware folder, its located on archlinux at /usr/lib/firmware.

I just started with CachyOS. I mean I saw “MT7961” with dmesg. It looks like that I now have messed up something with USB. After reboot the mouse needs 5 Minutes to come back. I rolled back a “CloneZilla Image”. Maybe I can downgrade to 6.8.

You can find here old kernels:

In the CachyOS Kernel Manager there is a “cachyos-v4/linux-cachyos-hardened” 6.8.9-4.
Is this “okay” for Ryzen 7 7800X3D ?

Uffff I think the downgrade will not work with the Kernel Manager.
Was hopping it is easy to get my Bluetooth to work again.
I use a ASUS B650E-F Gaming Motherboard.

Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von linux-cachyos-hardened verletzt Abhängigkeit »linux-cachyos-hardened=6.8.9-4«, benötigt von linux-cachyos-hardened-nvidia
:: Entfernen von linux-cachyos verletzt Abhängigkeit »linux-cachyos=6.9.1-2«, benötigt von linux-cachyos-nvidia
:: Entfernen von linux-cachyos-rc verletzt Abhängigkeit »linux-cachyos-rc=6.9.rc7-5«, benötigt von linux-cachyos-rc-nvidia
:: Entfernen von linux-cachyos verletzt Abhängigkeit »UKSMD-BUILTIN«, benötigt von uksmd-git
Press enter to exit

Why you want to remove these kernels?

Actually, you can simply downgrade with:
sudo pacman -U

Thank you for the support!

Did successful downgraded to linux-cachyos-6.8.9-7 - V4.
It says “No adapter found” and it is grayed out.

But I could still click on that grayed out Bluetooth Icon and was able to connect my Bluetooth Controller. I don’t get it. Thank you!

Okay and you were right, it was that with the “BT_RAM_CODE_MT7961_1a_2_hdr.bin” file. I have copied it into /lib/firmware/mediatek.

Now everything is fine under “6.9.0-rc7-5”
By the way is the Non-RC / Main-Version newer? That says “6.9.1-2”.

Thanks again buddy, It worked! Hopefully ill be able to solve a fix or problem for someone else in the community to pay it forward

1 Like

By the way is the Non-RC / Main-Version newer? That says “6.9.1-2”.

The “linux-cachyos” version is currently newer then the RC. The new RC (6.10) will come two weeks after 6.9 releases.

Now it is even more worst. Today the issue come back no Bluetooth at all plus after I see the Desktop I have to wait 3 to 4 minutes until my Keyboard and Mouse work. I see that then my audio devices getting re detected again.

What I’am doing wrong. I only copied yesterday those “.bin Firmware” to lib/firmware/mediatek.

Is there maybe a extra step? Sorry I’am a aboslut Linux beginner. Just wondering because yesterday everyting was fine. I go crazy

Actually, you need to copy it to /usr/lib/firmware/mediatek i guess.

You can also use the LTS Kernel until upstream is resolving that issue.

My USB has “long wait time issues”. I will restore my working “CachyOS” with my CloneZilla Image because I don’t know how to fix that. Then I will downgrade the Kernel, “signing secure boot” and reinstall my programs. I messed up my System 7 times but I like CachyOS so much. Big thanks.

The Bluetooth under LTS does work.
In the Kernel Manager → “is Configuration / Konfigurieren Sie” what is this?
Are those Patches good for Gaming/ CPU Performance / Optimization?

It looks like that it does auto Upgrade to 6.9.1-2. Can I apply those Patches somehow under LTS?

So far it looks good when I copy the Firmware to /usr/lib/firmware/mediatek then my Bluetooth also “survive” the restart.

There you can compile your own kernel, with own patches. For most users not required.

You can just install the lts kernel with:
sudo pacman -S linux-cachyos-lts linux-cachyos-lts-headers

Ahhh okay and in my case plus Nvidia ? This linux-cachyos-lts-nvidia necessary? I mean last time without nvidia it become unbootable or should I always do “sudo mkinitcpio -P” ?

“sudo pacman -S linux-cachyos-lts linux-cachyos-lts-headers linux-cachyos-lts-nvidia” ?

I think my Problem was that with “rEFInd” there was only one Kernel (the default) to select.
The other where not shown. I know with GRUB it looks a bit different. Maybe there is a way to get multiple selections with rEFInd.

But for now everything is fine. Feels very smooth. Hunt Showdown runs amazing. CachyOS best!

After “pacman -Syu” the problem came back and everything was messed up.
The mouse takes forever to load until restart. Bluetooth stopped working.

So I had to restore my backup again.
I will stick with LTS Kernel until the problem is finally sloved.

Thank you for the information ;D