Wake up from Sleep causes WM to crash

Hey pretty much what the subject says. Every time I put my desktop in sleep and try to login the WM I have to restart my PC to get it to work normally.

Operating System: CachyOS Linux
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.8-2-cachyos (64-bit)
Graphics Platform: Wayland
Processors: 24 Ɨ AMD Ryzen 9 5900X 12-Core Processor
Memory: 31.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3080/PCIe/SSE2

Iā€™m going to try this to see if it fixed my issue because I did have the same issue on another distro. How to fix the sleep/suspend Issue/glitch with crashing Nvidia propietary drivers and X11 / Wayland on KDE Plasma, Arch/ EndeavourOS - Kernel, boot, graphics & hardware - EndeavourOS

Hi,

You need to enable the nvidia services.
These are the services which need to be enabled:

sudo systemctl enable nvidia-suspend.service
sudo systemctl enable nvidia-hibernate.service
sudo systemctl enable nvidia-resume.service

Then create following file /etc/modprobe.d/nvidia.conf and add there:
options nvidia NVreg_PreserveVideoMemoryAllocations=1

After that reboot and suspend/sleep should work fine. Be aware that its still sometimes problematic on wayland with nvidia.

1 Like