[Testing] July Testing ISO is up

Hey together,

Our July Testing ISO is up. Release is planned in 1 week.
The ISO/Calamares has been pretty base tested in QEMU and also on bare bones hardware.

Download:
EU: Nginx Directory
US: us.cachyos.org
Korea: https://kr.cachyos.org/ISO/testing

The ISO more or less includes all changes, which will be in the final release, here you can find a little changelog:

Features:

  • Repository: Introduce Zen 4 optimized repository, this will be used for Zen4 and Zen5 CPU’s
  • ISO: Add automatic architecture check for Zen4/Zen5 repository
  • chwd: Added GC support for AMD GPU’s, this helps for detecting official ROCm supported GPUs
  • chwd: Use libva-nvidia-driver on supported cards
  • ksmctl: Introduce tool to enable/disable KSM: ksmctl --enable
  • Kernel: For the “linux-cachyos” kernel is now a “linux-cachyos-dbg” package available, this contains an unstripped vmlinux for debugging purposes
  • kernel: amd cpb boost is now available and the power-profiles-daemon is patched, if the “powersave” profile is set, it will disable the boost on amd cpus
  • kernel-manager: Added support for managing sched-ext schedulers and getting information via GUI
  • steam/proton: There is now a “game-performance” script, which can be added to steam’s launch options
  • power-profiles: On AMD Pstate supported CPUs the Linear frequeny is now set higher, this can improve latency and 1% lows
  • kwin: Added backport for tearing, this has been tested. On NVIDIA it only works on native wayland applications
  • netinstall: Cutefish has been dropped as installable Desktop Environment
  • Mirrors: Added Austria and China Mirror, the China Mirror is hosted by the TUNA University. This should help a lot of users from china
  • Package Updates: linux-cachyos 6.9.7, mesa 24.1.3, NVIDIA 555.58.02, Plasma 6.1.2

Bug Fixes:

  • ISO: Set copytoram to auto instead of yes
  • Launch Installer: Install the latest archlinux-keyring, before the installation starts to avoid issues, when fetching the archlinux-keyring in the chroot
  • Mirrors Ranking: Rank only Tier 1 Mirror’s at installation time, to avoid issues
  • pacman.conf: Remove not used pacman repository
  • cachy-chroot: Do not show .snapshot subvolumes
  • Calamares: Do not use “Preservefiles” module, since user a reporting issues with it.
6 Likes

There are still quite some errors, pressent in current iso also

No background in grub missing /usr/share/wallpapers and Gnome menu “app-picker” not sorting apps in folders anymore.

No background in grub missing /usr/share/wallpapers

After the installation? Did you maybe untick “cachyos-wallpapers”?

Gnome menu “app-picker” not sorting apps in folders anymore.

Needs to be reported to Gnome. We only ship a stock Gnome now.

No using the default installer option, i dont think there even is at option to uncheck wallpapers.

But /etc/default/grub refers to GRUB_BACKGROUND=‘/usr/share/wallpapers/cachyos-wallpapers/splash.png’

Thanks, Ill check that out. Actually there was nothing changed related to this, but I take a watch.

I think i did saw the issue. The CachyOS-Wallpapers package is only installed for KDE right now. Ill move it.

Will be solved with the release on sunday.

Its good that you stick with the 6.9 kernels until the 6.10rc display corruption issue on higher refresh rates (120+ hz) on the amd 6000 series is fixed.

Yes, and thank you very much for bisecting. I looked into the issue, and it seems that AMD also took now over the issue. Really glad to see.

FYI - for Zen4 is now a linux-cachyos-lto kernel included. We have patched LLVM, so that we can compile kernels with LTO for the Zen4 target

1 Like

I was going to install CachyOS on my pc, I guess its better to wait till Sun, right? even though I think installing any release till now and then doing pacman -Syu should theoretically yield same result, but I’m guessing there will be some leftovers etc?

CachyOS is a rolling distro. I would just suggest you to use the above testing ISO, if you want to install this now :slight_smile:

Great, thanks! But somehow 6.9.9 isn’t making it?

I have not triggered the LTO compilation yet, since I need to trigger the LTO one manually.