Snapper issue + rsync

I took a snapshot for both home and root before installing a game in bottle , then i rolled back , here the folder game in home not found also the data for it in the system but the issue that the drive size remains the same when the game installed 257 after restoring the snapahot 257 ( i was waiting to see at least +40Gb "the size of removed game " ) and that didnt happened with only game so any fix for that + is rsync timeshift better then snapper maybe this case is a bug in btrfs assistant

Actually, the automatic snapshot for the home is only done every X hours (i guess).

And, the root gets snapshot’d after every update. I’ve tested it quite much in QEMU and all worked fine. But I will recheck.

cc: @nekoh

I disabled the automatic snapshots i took only 2 manuals once for both home and root ( vefore installing a 40 gb game ) then when i wanted to restore the size of the drive still the same but when i checked the game is deleted and other files also deleted i was expecting to restore the old size so is it a bug or something

even after a period of time waiting balance to finish it still the same issue the drive still have the same volume and am expecting to free it after restoring the snapshot +50 Giga but it still the same even that the game is deleted from both home and system those are the sources( It seems that restoring a snapshot through btrfs-assistant did not change the used space on your disk. This could be due to a few reasons:

  1. Btrfs snapshots are copy-on-write (CoW)[1][5]. When you create a snapshot, it initially shares data blocks with the original subvolume. The snapshot only consumes additional space when files in the original subvolume are modified or deleted[5]. Restoring a snapshot does not automatically reclaim space from deleted files.

  2. Btrfs uses a background process called balance to optimize space usage[2]. After restoring a snapshot, you may need to run a balance operation to reclaim space from deleted files. The command is:

sudo btrfs balance start -dusage=0 -musage=0 --bg /path/to/mountpoint ( here i simply pushed the button in btrfs assistant )

This will free up completely unused blocks in the background[2].

  1. Btrfs assistant may not be handling the restore properly due to your custom subvolume layout[4]. If you are using a non-standard layout instead of Snapper’s default, btrfs assistant may need additional configuration to know where to restore snapshots to[4]. Manually running the restore commands may work better.

In summary, restoring a snapshot does not automatically reclaim space. You likely need to run a balance operation to optimize space usage after the restore. If issues persist, check your subvolume layout and consider using the btrfs commands directly instead of the assistant.

Citations:
[1] https://www.reddit.com/r/btrfs/comments/xdh3c8/btrfs_restore_sucks/
[2] BTRFS disk Full how to fix it, is that really the solution? - Install/Boot/Login - openSUSE Forums
[3] How does btrfs scrub work and what does it do? - Super User
[4] I need a little help with brtrfs-assistant restore feature - Applications - EndeavourOS
[5] What is Btrfs in Linux? What are its Advantages Over Ext4? )

Still couldn’t find a solution for the issue. I waited for the balance to complete, but nothing changed. Additionally, the scrub button stops working after about one minute. I would be grateful for any help.

@nekoh
Wrote in the discord, that before restoring via btrfs-asssistant it asks you to generate an snapshot. Could this maybe the issue?

1 Like

Thanks For the help