Opensnitch not working

hi cachy seems to have the same issue as other arch systems regarding opensnitch. i have tried to follow the instructions from this site " There're no nodes connected, can't save settings. · Issue #883 · evilsocket/opensnitch · GitHub"
but when i try to follow the instructions i get an error
"[root@bright-star7 gazza]# pip3 install --user grpcio==1.44.0
error: externally-managed-environment

× This environment is externally managed
╰─> To install Python packages system-wide, try ‘pacman -S
python-xyz’, where xyz is the package you are trying to
install.

If you wish to install a non-Arch-packaged Python package,
create a virtual environment using 'python -m venv path/to/venv'.
Then use path/to/venv/bin/python and path/to/venv/bin/pip.

If you wish to install a non-Arch packaged Python application,
it may be easiest to use 'pipx install xyz', which will manage a
virtual environment for you. Make sure you have python-pipx
installed via pacman."

and so cant fix the problem !
anyone else had to deal with this ? or got the fix ?

Have you tried “sudo pacman -S python-grpcio”? That is the way to install python packages now (i.e., don’t use pip3).

thank you for replying
the package is already installed, but the fix for opensnitch says i need to downgrade grpcio to version 1.44.0. when i tried your suggestion, it just reinstalled the latest version 1.62.1

regards
gaz

1 Like

pip3 does not work anymore, due changed in PEP538.
You can try it with “pipx” which creates an own env.

If you need an older version you can try following:

pkgctl repo clone --protocol=https python-grpcio
cd python-grpcio
# Change pkgver
makepkg -si --skipchecksums

Personally I don’t think this will work, since the pkg is waay to old.