Nvidia error when trying to update

After trying sudo pacman -Syu, the following error:

:: Synchronizing package databases...
 cachyos-v3 is up to date
 cachyos-core-v3                             51,2 KiB  81,7 KiB/s 00:01 [----------------------------------------] 100%
 cachyos-extra-v3                          2010,3 KiB  2,10 MiB/s 00:01 [----------------------------------------] 100%
 cachyos                                    480,3 KiB   613 KiB/s 00:01 [----------------------------------------] 100%
 core                                       121,6 KiB   169 KiB/s 00:01 [----------------------------------------] 100%
 extra                                        7,9 MiB  6,44 MiB/s 00:01 [----------------------------------------] 100%
 multilib                                   138,9 KiB   195 KiB/s 00:01 [----------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (555.58.02-2) breaks dependency 'nvidia-utils=555.58' required by nvidia

Sorry, we do not provide the nvidia module for the default arch kernel. Either remove it or switch to nvidia-dkms.

1 Like

Is this a good way to do it?

sudo pacman -R nvidia
sudo pacman -Syu

sudo pacman -Syu is working now.

1 Like