No caps lock indicator in system tray KDE

Hello all,

On KDE Plasma there used to be an indicator that appeared in the system tray when the caps lock key is activated. I currently do not see this option and when I open the system tray there is no entry for lock key status shown.

Is there any way to enable this?

Blockquote
System:
Host: cachyos-x8664 Kernel: 6.9.3-2-cachyos arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.5 Distro: CachyOS
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE WIFI v: -CF
serial: N/A
Mobo: Gigabyte model: X570 AORUS ELITE WIFI serial: N/A UEFI: American
Megatrends LLC. v: F38f date: 09/20/2023
CPU:
Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP cache:
L2: 6 MiB
Speed (MHz): avg: 2325 min/max: 2200/4950 cores: 1: 2200 2: 2200 3: 3700
4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
13: 3700 14: 2200 15: 2200 16: 2200 17: 2200 18: 2200 19: 2200 20: 2200
21: 2200 22: 2200 23: 2200 24: 2200
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
v: kernel
Display: server: X.Org v: 24.1 with: Xwayland v: 24.1.0 driver: X:
loaded: modesetting dri: radeonsi gpu: amdgpu resolution: 3440x1440~240Hz
API: EGL v: 1.5 drivers: radeonsi,swrast
platforms: gbm,x11,surfaceless,device
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.0-arch1.2
renderer: AMD Radeon RX 6800 XT (radeonsi navi21 LLVM 17.0.6 DRM 3.57
6.9.3-2-cachyos)
API: Vulkan v: 1.3.285 drivers: radv surfaces: xcb,xlib
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-3: Corsair Slipstream Multi-Device Receiver
driver: hid-generic,snd-usb-audio,usbhid type: USB
Device-4: SteelSeries ApS Arctis Nova Pro Wireless
driver: hid-generic,snd-usb-audio,usbhid type: USB
Device-5: Logitech Logi Z407 driver: hid-generic,snd-usb-audio,usbhid
type: USB
API: ALSA v: k6.9.3-2-cachyos status: kernel-api
Network:
Device-1: Intel Wi-Fi 5 Wireless-AC 9x6x [Thunder Peak] driver: iwlwifi
IF: wlan0 state: up mac: 98:8d:46:93:51:16
Device-2: Intel I211 Gigabit Network driver: igb
IF: enp6s0 state: down mac: 18:c0:4d:84:68:f6
Bluetooth:
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb type: USB
Report: btmgmt ID: hci0 state: up address: 98:8D:46:93:51:1A bt-v: 5.1
Drives:
Local Storage: total: 2.73 TiB used: 207.2 GiB (7.4%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 2000GB
size: 1.82 TiB
ID-2: /dev/nvme1n1 vendor: Corsair model: Force MP600 size: 931.51 GiB
Partition:
ID-1: / size: 391.21 GiB used: 9.76 GiB (2.5%) fs: btrfs dev: /dev/nvme0n1p2
ID-2: /boot size: 2 GiB used: 217.8 MiB (10.7%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 1003.49 GiB used: 197.23 GiB (19.7%) fs: btrfs
dev: /dev/nvme0n1p3
ID-4: /var/log size: 391.21 GiB used: 9.76 GiB (2.5%) fs: btrfs
dev: /dev/nvme0n1p2
ID-5: /var/tmp size: 391.21 GiB used: 9.76 GiB (2.5%) fs: btrfs
dev: /dev/nvme0n1p2
Swap:
ID-1: swap-1 type: zram size: 31.26 GiB used: 768 KiB (0.0%) dev: /dev/zram0
Sensors:
System Temperatures: cpu: 39.0 C mobo: 33.0 C gpu: amdgpu temp: 57.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 1070
Blockquote

I don’t think that is something that is included in plasma 6. It might be something they got rid of. I just checked my self and yeah, I don’t think it made the cut from 5 to 6.