Issues trying to run Gnome web nightly

Hello!

New CachyOS user here. Really enjoying the experience for nvidia + hyrpland as this is one of the few distributions that has a fantastic config ootb.

I am trying to run the nightly flatpak of Epiphany but am running into the following error

❯ flatpak run org.gnome.Epiphany.Devel
DRM kernel driver 'nvidia-drm' in use. NVK requires nouveau.

(epiphany:2): Gdk-CRITICAL **: 15:41:29.820: Vulkan: ../src/nouveau/vulkan/nvk_physical_device.c:1109: VK_ERROR_INCOMPATIBLE_DRIVER

~

I am running into this error after essentially a fresh install and have not messed around with the nvidia drivers and am working on the propriety drivers. I am wondering how I could go about debugging this issue and getting the nightly version of web running on my system.

I did find this on the nix os forums. It indicates that it is an opengl problem? something to do with vulkan? but I couldn’t piece it together.

Would really appreciate any hints to debug this issue! Thanks!

Do you have the vulkan-nouveau package installed?

❯ pacman -Q | grep -E "vulkan|nvidia|mesa"
lib32-libva-mesa-driver 1:24.1.1-2
lib32-mesa 1:24.1.1-2
lib32-mesa-vdpau 1:24.1.1-2
lib32-nvidia-utils 555.52.04-1
lib32-opencl-nvidia 555.52.04-1
lib32-opencl-rusticl-mesa 1:24.1.1-2
lib32-vulkan-icd-loader 1.3.279-1
lib32-vulkan-radeon 1:24.1.1-2
libva-mesa-driver 1:24.1.1-2
libva-nvidia-driver 0.0.12-1.1
linux-cachyos-nvidia 6.9.3-4
mesa 1:24.1.1-2
mesa-utils 9.0.0-4.1
mesa-vdpau 1:24.1.1-2
nvidia-settings 555.42.02-2
nvidia-utils 555.52.04-2
opencl-nvidia 555.52.04-2
opencl-rusticl-mesa 1:24.1.1-2
vulkan-headers 1:1.3.285-1
vulkan-icd-loader 1.3.285-1.1
vulkan-radeon 1:24.1.1-2
vulkan-validation-layers 1.3.275-1.1

I do not have the vulkan-nouveau package installed

Oh, since you are using flatpak, my guess would be that flatpak has preinstalled it.
How about using a native package?

Thanks for the hint that the flatpak has it preinstalled. I was able to get the flatpak version to run by uninstalling org.freedesktop.Platform.GL.default but I’m sure that would cause a ton of other problems so I did not continue to use that method.

I am now using the native version which worked! Thanks for the quick responses!

1 Like