Install Gaming packages Issue

When installing gaming packages . I run into this error .

resolving dependencies...
:: There are 2 providers available for sdl:
:: Repository cachyos-extra-v3
   1) sdl12-compat
:: Repository extra
   2) sdl12-compat

Enter a number (default=1):
:: There are 15 providers available for xdg-desktop-portal-impl:
:: Repository cachyos-extra-v3
   1) xdg-desktop-portal-dde  2) xdg-desktop-portal-gnome  3) xdg-desktop-portal-gtk
   4) xdg-desktop-portal-hyprland  5) xdg-desktop-portal-kde  6) xdg-desktop-portal-lxqt
   7) xdg-desktop-portal-xapp
:: Repository extra
   8) xdg-desktop-portal-dde  9) xdg-desktop-portal-gnome  10) xdg-desktop-portal-gtk
   11) xdg-desktop-portal-hyprland  12) xdg-desktop-portal-kde  13) xdg-desktop-portal-lxqt
   14) xdg-desktop-portal-wlr  15) xdg-desktop-portal-xapp

Enter a number (default=1):
:: There are 2 providers available for libjpeg6:
:: Repository cachyos-extra-v3
   1) libjpeg6-turbo
:: Repository extra
   2) libjpeg6-turbo

Enter a number (default=1):
:: There are 5 providers available for xorg-server-xwayland:
:: Repository cachyos-v3
   1) xorg-xwayland
:: Repository cachyos-extra-v3
   2) xorg-xwayland
:: Repository cachyos
   3) xorg-xwayland  4) xorg-xwayland-git
:: Repository extra
   5) xorg-xwayland

Enter a number (default=1):
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing util-linux-libs (2.40.1-1) breaks dependency 'util-linux-libs=2.40.2' required by util-linux

I have a similar issue, when I do “sudo pacman -Syu” it also says

error: failed to prepare transaction (could not satisfy dependencies)
:: installing util-linux-libs (2.40.2-1.1) breaks dependency ‘util-linux-libs=2.40.1’ required by util-linux

I was able to fix this. I just opened “CachyOS Hello” and under “Apps-Tweaks”
I did the “Rank-Mirrors” again.

That was all, after that it did the Updates again.

1 Like