How can I install cachyos in a network with corporate proxy

As title says, I’m experiencing problems with installation of cachyos in a network with corporate proxy. I’m trying to install it in virtualbox under windows host.
The KDE network manager says my device is connected, but no internet connection available and the cachy os hello app resists to install distro since no internet connection.
Even though I set up proxy in network manager, I can ping google.com through terminal, but the cachyos hello still thinks I’m not connected to internet. Same for browser: it doesn’t reach google.com

I think you are not passing the network from the host properly. Is maybe your corp blocking this?

Investigating it further. If I set proxy into the cachyos browser settings directly, I can connect to internet. It seems like only the network manager proxy settings are being ignored. I can’t force cachyos hello to use proxy somehow?

Sooo, forcing the HTTP_PROXY and HTTPS_PROXY variables on /etc/environment and relogging to live cd seems like a fix for an issue

1 Like