Doesn't auto resize desktop resolution in a QEMU vm

Fresh install Gnome. It’s installed in the system session not in the user session. qemu-ga channel was added to the guest. Virtio display with opengl.

Im not sure about gnome, but KDE does automatically resize the desktop resolution.

I am not on gnome, but have you enabled the auto resize option in the the virt-manager menu?